# Verwenden des Dateimanagers in KPanel

Source: https://support.kapsulehost.com/de-de/file-manager

Der KPanel File Manager ermöglicht es dir, deine Website-Dateien direkt in deinem Browser zu bearbeiten. Du kannst Verzeichnisse durchsuchen, Dateien hochladen, neue Dateien und Ordner erstellen, Code bearbeiten und Elemente löschen, ohne einen FTP- oder SFTP-Client installieren zu müssen.

### File Manager öffnen

1. Melden dich bei KPanel unter [kpanel.kapsulehost.com](https://kpanel.kapsulehost.com) an
2. Gehe zu **Websites** und wähle die Website aus, die du verwalten möchtest
3. Klicke auf **File Manager**

Der File Manager öffnet sich und zeigt das Wurzelverzeichnis deiner ausgewählten Website an.

### Deine Dateien navigieren

Verwende den Ordnerbaum, um durch Verzeichnisse zu navigieren. Häufige Verzeichnisse sind:

- `public_html/` oder das Site-Root-Verzeichnis, deine öffentlich zugänglichen Website-Dateien
- `wp-content/`, WordPress-Themes, Plugins und Uploads (für WordPress-Websites)
- `logs/`, Server-Fehler- und Zugriffsprotokolle (siehe [Auf deine Website-Fehlerprotokolle zugreifen](https://support.kapsulehost.com/de-de/error-logs))

### Dateien hochladen

1. Navigiere zum Verzeichnis, in das du hochladen möchtest
2. Klicke auf **Upload**
3. Wähle eine oder mehrere Dateien von deinem Computer aus
4. Der Upload beginnt sofort

Für große Dateiübertragungen oder Massen-Uploads ist SFTP schneller und zuverlässiger. Siehe [SFTP Access](https://support.kapsulehost.com/de-de/sftp-access).

> **Tip:** Der File Manager hat eine Größenbeschränkung pro Datei beim Upload. Für Dateien größer als 50 MB verwende stattdessen SFTP.

### Dateien und Ordner erstellen

- Um eine neue Datei zu erstellen: klicke auf **New File**, gib einen Namen ein (einschließlich der Erweiterung) und klicke auf **Create**
- Um einen neuen Ordner zu erstellen: klicke auf **New Folder**, gib einen Namen ein und klicke auf **Create**

### Dateien bearbeiten

1. Klicke auf die Datei, die du bearbeiten möchtest
2. Klicke auf **Edit** (oder doppelklicke auf die Datei)
3. Ein Code-Editor öffnet sich in deinem Browser
4. Nimm deine Änderungen vor und klicke auf **Save**

> **Warning:** Das direkte Bearbeiten von Dateien auf deiner Live-Website ist mit Risiken verbunden. Ein Syntaxfehler in einer PHP-Datei kann einen [weißen Bildschirm](https://support.kapsulehost.com/de-de/wordpress-white-screen) oder einen 500-Fehler verursachen. Für größere Code-Änderungen arbeite zunächst in einer Staging-Umgebung. Siehe [Staging-Umgebungen verwenden](https://support.kapsulehost.com/de-de/staging-environments).

### Berechtigungen

Dateiberechtigungen kontrollieren, wer jede Datei lesen, schreiben oder ausführen kann. Standardberechtigungen für WordPress sind `644` für Dateien und `755` für Verzeichnisse.

> **Note:** Setze Dateien nicht auf `777`, es sei denn, dies wird speziell von der Dokumentation eines Plugins angewiesen, da dies ein Sicherheitsrisiko darstellt.
