# SSL証明書とHTTPS

Source: https://support.kapsulehost.com/ja-jp/ssl-certificates

KapsuleHostがどのようにSSLを自動的に処理するか、また証明書に問題が発生した場合にどうすればよいかを、平易な言葉で説明します。

---

## SSLとは何か、なぜ重要なのか

誰かがあなたのウェブサイトを訪れると、そのブラウザとサーバーの間で情報がやり取りされます。SSLがない場合、その情報は平文で送信されます。ネットワーク接続を監視している人は誰でも、パスワードやフォームの送信内容、個人情報を含めて、それを読み取ることができてしまいます。

SSL(Secure Sockets Layerの略で、技術的には現在TLSと呼ばれていますが、一般にはまだSSLと呼ばれています)は、この接続を暗号化します。ブラウザのアドレスバーに表示される鍵アイコンは、SSLが有効で接続が安全であることを示す視覚的なサインです。

セキュリティ以外にも、SSLが重要である実用的な理由があります。

- **Googleは安全なサイトを上位に評価します。** HTTPSを使用していないウェブサイトは、検索結果で順位が下がることがあります。
- **ブラウザが警告を表示します。** Chrome、Safari、Firefoxはいずれも、SSLのないサイトを訪れた訪問者に対して「保護されていません」という警告を表示します。
- **フォームやログインにはSSLが必要です。** 最新のブラウザは、設定によってはHTTPS以外のページでのフォーム送信をブロックします。

**要するに:** 稼働中のすべてのウェブサイトにはSSLが有効になっているべきです。KapsuleHostはこれを自動的に処理するため、お客様が手動で証明書を購入したりインストールしたりする必要はありません。

---

## KapsuleHostがSSLを自動的に処理する仕組み

KPanelでサイトを作成し、ドメインのDNSがKapsuleHostを指している場合、[SSL証明書](https://kapsulehost.com/ja-jp/protect/ssl)が自動的にリクエストされ、インストールされます。お客様が次のことを行う必要はありません。

- 証明書を購入する
- CSR(証明書署名要求)を生成する
- 証明書ファイルをアップロードする
- 手動で何かを設定する

KapsuleHostは業界標準の証明書インフラストラクチャを使用して、すべてのサイトに証明書を発行・インストールします。証明書はルートドメインとwwwサブドメインの両方をカバーします。

---

## SSLが発行されるタイミング

SSL証明書は、次の2つの条件が満たされると自動的に発行されます。

1. **ドメインが[お客様のKapsuleHostアカウントに追加されている](https://support.kapsulehost.com/ja-jp/adding-your-domain)**(KPanel > ドメインに表示されます)
2. **DNSが伝播しており**、ドメインのAレコードがお客様のKapsuleHostサーバーを指している

両方の条件が満たされると、証明書の発行が自動的に開始されます。通常の条件下では、DNSが伝播してから**5分から15分以内**にサイトに緑色の鍵アイコンが表示されます。

> **Note:** DNSが伝播する前にSSLを発行することはできません。ドメインをKapsuleHostに向けたばかりの場合、DNSが世界中に伝播してSSLが有効になるまで、数時間お待ちいただく必要があるかもしれません。これは正常な現象であり、想定どおりの動作です。

---

![KPanelでSSLステータスを表示するウェブサイト概要ページ](https://support.kapsulehost.com/help/screenshots/ssl-certificates-overview.1c20e61b.webp)

## KPanelにおけるSSLステータスの表示

KPanelの**ウェブサイト**では、各サイトにSSLステータスの表示が示されます。

| ステータス | 意味 |
|---|---|
| 緑色の鍵アイコン / アクティブ | SSLは有効で、サイトは完全にHTTPS化されています |
| 保留中 | 証明書がリクエストされ、DNSまたは発行の完了を待っています |
| 失敗 | 証明書を発行できませんでした。下記のトラブルシューティングをご覧ください |
| まもなく期限切れ | 証明書の有効期限まで30日以内です(更新は自動で行われるため、これは情報提供のみです) |

---

## SSLが発行されない場合の対処法

30分経過してもSSLが保留中または失敗のままで、DNSは伝播していると思われる場合は、次のチェックリストを確認してください。

### 1. DNSが伝播していることを確認する

DNS伝播チェックツール(「DNS propagation checker」でウェブ検索すると見つかります)を使用してください。ドメインを入力し、ほとんどの場所でAレコードがKapsuleHostのIPアドレスに解決されるかどうかを確認します。

解決されない場合は、DNSがまだ完全に伝播していません。さらに1時間待ってから再度確認してください。

### 2. KPanelでドメインがアクティブであることを確認する

KPanelの**ドメイン**に移動し、ドメインが「アクティブ」または「接続済み」と表示されていることを確認してください。「保留中」と表示されている場合は、レジストラからDNSがまだ伝播していません。

### 3. CAAレコードの競合を確認する

CAA(証明機関認可)レコードは任意の[DNSレコード](https://support.kapsulehost.com/ja-jp/dns-basics)で、お客様のドメインに対してどの認証局がSSLを発行できるかを制御します。以前のプロバイダーから残っているCAAレコードがドメインにある場合、KapsuleHostの認証局をブロックしている可能性があります。

確認方法:
1. KPanel > **ドメイン** > 該当のドメイン > **DNSとネームサーバー**に移動します
2. **CAA**タイプのレコードがないか確認します
3. KapsuleHostが必要とする内容と一致しないCAAレコードが見つかった場合は、それを削除するか、サポートにお問い合わせください

> **Tip:** CAAレコードが問題の原因かどうか判断がつかない場合は、ドメイン名を添えてsupport@kapsulehost.comまでサポートにお問い合わせください。サポートチームは数分以内にこれを診断できます。

### 4. ドメインが正しいサイトを指していることを確認する

KPanelに複数のサイトがある場合、ドメインが正しいサイトに割り当てられていることを確認してください。**ウェブサイト** → 該当のサイト → **設定**に移動し、表示されているドメインが、保護しようとしているドメインと一致しているか確認します。

### 5. wwwとルートドメインの競合を確認する

SSLは`yourdomain.com`と`www.yourdomain.com`の両方に対して発行されます。`www`のCNAMEレコードがKapsuleHost以外の場所を指している場合、www版の証明書が失敗する可能性があります。DNS設定でAレコードとCNAMEレコードの両方を確認してください。

---

## 証明書の更新: 完全自動化

KapsuleHostは、証明書の有効期限が切れるおよそ30日前にSSL証明書を自動的に更新します。お客様が何かを行う必要はありません。

更新時期が近づくと、KPanelに「まもなく期限切れ」という通知が表示されることがあります。これは情報提供のみです。更新処理はバックグラウンドで実行され、更新中にサイトがダウンタイムを経験することはありません。

> **Warning:** お客様のドメインのDNSがKapsuleHostを指さなくなった場合(例えば、ネームサーバーがレジストラのデフォルトに戻された場合など)、認証局がドメインの所有権を確認できないため、自動更新は失敗します。ドメインをKapsuleHostから移行する予定がある場合、新しい証明書が手配されない限り、SSLは最終的に期限切れとなり、移行先のサーバーでブラウザの警告が表示されることにご注意ください。

---

## SSLの有効期限が切れるとどうなるか

証明書が更新されずに有効期限が切れた場合:

- **訪問者には、接続が保護されていないことを示す全画面のブラウザ警告が表示されます。** ほとんどの訪問者はこの警告を超えて先に進みません。
- **検索エンジンがサイトを安全でないとみなすため、検索順位が下がる可能性があります。**
- **最新のブラウザによってフォーム送信がブロックされる可能性があります。**

通常の状況では、更新が自動的に行われるため、KapsuleHostでこれが発生することはありません。期限切れが発生し得る唯一のケースは、ドメインのDNSが他の場所を指すように変更され、自動更新が妨げられた場合です。

> **Important:** 稼働中のサイトでSSLの期限切れ警告が表示された場合は、直ちにsupport@kapsulehost.comまでサポートにお問い合わせください。ドメイン名を添えてください。サポートチームが更新の失敗なのかDNS設定の問題なのかを診断し、できるだけ早くHTTPSを復旧します。

---

## よくある質問

**自分のSSL証明書をアップロードできますか?**
ほとんどのサイトでは、自動的に発行される証明書で問題なく、独自の証明書は必要ありません。有料の拡張検証(EV)証明書やワイルドカード証明書について特定の要件がある場合は、サポートにお問い合わせのうえご相談ください。

**サブドメインでもSSLは機能しますか?**
はい。KPanelでサブドメイン(例えば`shop.yourdomain.com`)にサイトを作成すると、そのサブドメイン用のSSL証明書が自動的に発行されます。

**サイトはHTTPで読み込まれますが、HTTPSへのリダイレクトでエラーが表示されます。**
これは通常、[混在コンテンツの問題](https://support.kapsulehost.com/ja-jp/ssl-mixed-content)です。サイトはHTTPSで読み込まれているものの、一部のリソース(画像やスクリプト)が依然として`http://`のURLで参照されている状態を指します。WordPressでは、**設定 > 一般**に移動し、WordPressアドレスとサイトアドレスの両方が`https://`を使用していることを確認してください。「Better Search Replace」のようなプラグインを使うと、データベース内に残っている`http://`への参照を更新するのに役立ちます。
