# 理解退回消息和SMTP代码

Source: https://support.kapsulehost.com/zh-cn/email-bounce-codes

当消息无法投递时，您会收到一个退信，其中隐藏着一个数字代码，它会准确告诉您原因是什么、是否会最终成功投递，以及问题出在哪一端。

大多数人会阅读退信顶部的人类语句，认为它没有帮助，然后放弃。这句话是由拒绝邮件的服务器生成的，通常表述模糊。而代码则不然。本文是您实际会看到的代码的参考资源，以及针对各个代码应采取的措施。

## 如何阅读退信

退信包含两个数字。

**回复代码**是三位数字，如 `550` 或 `451`。第一位数字最重要:

- **4xx** 是暂时性的。接收服务器目前无法接收消息。您的邮件服务器会在一段时间内继续重试，它可能会自动成功。暂时不需要做任何事情。
- **5xx** 是永久性的。接收服务器将永不接受此消息。重试不会改变任何情况。必须先做出改变。

**增强状态代码**是由点分隔的三个数字，如 `5.1.1` 或 `4.2.2`。它提供具体原因，遵循相同的规则：以 5 开头是永久性的，以 4 开头是暂时性的。

所以 `550 5.1.1 User unknown` 是永久性的，表示该地址不存在。`452 4.2.2 Mailbox full` 是暂时性的，表示稍后重试。

> **Tip:** 如果退信没有明确说明问题所在，请在网上搜索确切的增强状态代码加上接收方提供商的名称。每个大型提供商都会发布自己的代码列表，该页面会准确告诉您它们对代码的含义，通常比标准定义更具体。

## 永久性故障（5xx）

| 代码 | 通常表示 | 应采取的措施 |
|---|---|---|
| `550 5.1.1` | 收件人地址不存在 | 检查拼写。如果拼写正确，该地址已被关闭。从您的记录中删除它。 |
| `550 5.1.2` | 收件人的域不存在或没有邮件服务器 | 检查域名拼写。如果正确，他们的域没有有效的 MX 记录，需要他们自己修复。 |
| `550 5.7.1` | 被策略拒绝。这是身份验证失败、黑名单列表和内容规则的统一拒绝 | 阅读消息的其余部分。这个通常会指向 SPF、DKIM、DMARC 或黑名单列表。 |
| `550 5.7.26` | 接收方提供商要求身份验证，您的域未通过验证 | 修复 SPF 和 DKIM。请参阅 [SPF、DKIM 和 DMARC 说明](https://support.kapsulehost.com/zh-cn/spf-dkim-dmarc)。 |
| `551` | 该地址不在此处处理，且不存在转发路径 | 使用正确的地址。 |
| `552 5.2.2` | 收件人的邮箱超过其存储限制，永久拒绝 | 通知收件人。您这一端无法解决。 |
| `553 5.1.3` | 该地址在语法上无效 | 修复地址格式。 |
| `554 5.7.1` | 交易被直接拒绝，通常在连接时 | 通常是黑名单列表或硬策略阻止。请参阅 [从黑名单列表中解除列表](https://support.kapsulehost.com/zh-cn/email-blacklist-delisting)。 |

## 暂时性故障（4xx）

| 代码 | 通常表示 | 应采取的措施 |
|---|---|---|
| `421 4.7.0` | 接收服务不可用或限制您的连接 | 无需操作。重试会处理它。如果持续数小时，接收方提供商正在限制您的速率。 |
| `450 4.2.1` | 邮箱暂时不可用，通常是灰名单列表 | 无需操作。灰名单列表会故意延迟首次发送者，然后接受重试。 |
| `451 4.3.0` | 接收服务器上的本地错误 | 无需操作。重试会处理它。 |
| `452 4.2.2` | 收件人的邮箱已满 | 暂时无需操作。如果持续数天，请以其他方式联系收件人。 |
| `452 4.5.3` | 一条消息上的收件人过多 | 将消息分成较小的收件人批次。 |
| `4.4.1` | 未收到来自接收主机的回复 | 无需操作。他们的服务器已关闭或无法访问。 |
| `4.7.x` | 暂时性策略阻止，通常与信誉相关 | 查看您的域身份验证。年轻或验证不当的域会更频繁地被延迟。 |

> **Note:** 灰名单列表值得识别，因为它看起来令人担忧，但完全正常。接收服务器会故意以 4xx 拒绝未知发送者的第一次尝试，然后在几分钟后接受重试。如果您的邮件迟到但最终投递，灰名单列表可能是原因，无需修复。

## KapsuleHost 端生成的退信

有些退信来自我们的平台，而不是收件人的。这些是您可以直接控制的:

**收件人邮箱已满。** KapsuleHost 邮箱超过其存储限制会拒绝新邮件，发送者会收到说明这一点的退信。从您这一端使用 [我的邮箱已满](https://support.kapsulehost.com/zh-cn/email-mailbox-full) 来修复。

**该地址不存在。** 删除邮箱、[转发器](https://support.kapsulehost.com/zh-cn/email-forwarding)、[邮件列表](https://support.kapsulehost.com/zh-cn/email-mailing-lists) 或 [共享收件箱](https://support.kapsulehost.com/zh-cn/email-shared-inboxes) 意味着从那时起发往该地址的邮件会被退回。控制面板会在删除时警告您此事。域上的 [全捕获](https://support.kapsulehost.com/zh-cn/email-catch-all) 可以防止这种情况，代价是接收发送到每个错误拼写地址的所有内容。

**阻止规则拒绝了它。** 邮箱上的**垃圾邮件过滤**标签可让您阻止特定发送者和域，被阻止的邮件被拒绝而不是归档。如果同事报告被退回，请先检查该标签，再寻找其他地方。

**垃圾邮件评分过高。** 评分远超垃圾邮件阈值的邮件会在投递时被拒绝，因此发送者会被告知邮件未到达。评分适中的邮件会改为存档到垃圾箱，您可以在其中检索。没有任何内容被无声丢弃。

**达到发送限制。** 如果您是在发送时被拒绝的一方，您可能已达到 [电子邮件发送限制](https://support.kapsulehost.com/zh-cn/email-sending-limits) 中描述的每个邮箱速率限制。

## 硬退信与软退信

批量发送者使用两个非正式术语，对应上面的代码。**硬退信**是 5xx：该地址已失效，应从您的列表中永久删除。**软退信**是 4xx：值得重试的暂时性情况。

实用规则是硬退信地址必须在第一次退信时从列表中删除。继续邮寄永久失败的地址是最强的负面信誉信号之一，接收方提供商将其视为您不维护列表的证据。

> **Warning:** 如果大部分发送硬退信，请停止发送。一次活动中的高退信率将在随后数周内损害您域名的信誉，您在此期间发送的每条合法消息都会因此受损。清理列表，然后恢复。

## 确定问题出在谁这一端

- **来自每个提供商的每个收件人都退信。** 您的域或您的发送配置。从您邮箱上的**可投递性**标签开始，以及 [为什么我的电子邮件进入垃圾邮件？](https://support.kapsulehost.com/zh-cn/email-spam-sending)
- **来自一个提供商的每个收件人都退信。** 该提供商对您的域或发送基础设施有特定问题。阅读代码，然后检查该提供商的邮箱管理员工具。
- **一个收件人退信，其他所有人都没问题。** 他们的地址、他们的邮箱或他们组织的邮件规则。以其他方式与他们联系。
- **它突然开始，而您这一端没有任何改变。** 检查您的域或发送基础设施是否在某处被列表列出：请参阅 [从黑名单列表中解除列表](https://support.kapsulehost.com/zh-cn/email-blacklist-delisting)。

## 获得帮助

如果您有无法解释的退信，请 [提交支持工单](https://support.kapsulehost.com/zh-cn/opening-a-support-ticket)，并包含退信消息的**完整文本**，而不是摘要或第一行的屏幕截图。有用的信息在标题和最终服务器响应中，当退信被改述时两者都会丢失。包括发生的时间和收件人地址。

相关阅读: [为什么我的电子邮件进入垃圾邮件？](https://support.kapsulehost.com/zh-cn/email-spam-sending)、[电子邮件发送限制](https://support.kapsulehost.com/zh-cn/email-sending-limits)、[电子邮件未接收](https://support.kapsulehost.com/zh-cn/email-not-receiving) 和 [SPF、DKIM 和 DMARC 说明](https://support.kapsulehost.com/zh-cn/spf-dkim-dmarc)。
