すべてのKapsuleHostサーバーは1日1回、暗号化されたオフサイトストレージにバックアップされ、30日間保持されます。サーバーのKPanel内のページからいつでも追加のバックアップを取得したり、バックアップから復元したりできます。
バックアップはサーバーをプロビジョニングすると自動的に有効になります。設定するものがなく、インストールするエージェントもなく、設定するスケジュールもありません。このガイドでは、何がキャプチャされるか、バックアップリストの読み方、オンデマンドでバックアップを取得する方法、および復元が実行中のサーバーに何をするかについて説明します。
バックアップの保存場所
バックアップはサーバーに属しているため、メインメニューではなく、そのサーバーからアクセスします。
- KPanelにサインインします。
- 左サイドバーのCloud Serversをクリックし、目的のサーバーをクリックします。
- Backupsカードまでスクロールします。
直接アドレスは/cloud-servers/<server-id>です。

カードヘッダーには、最後に成功したバックアップの時刻が表示されます。最初のバックアップが完了する前に、代わりに説明文が表示されます: 「暗号化されたストレージへの日次オフサイトバックアップ、30日間保持」。
Cloud Serversはアカウントが実際にクラウドサーバーを持つまで、KPanelサイドバーに表示されません。表示されない場合は、アカウントにはまだサーバーがありません。
キャプチャの内容
Backupsカードの下部にあるWhat's in your backupを展開すると、サーバーのライブマニフェストが表示されます。これは5つのカテゴリに分類されています。
| カテゴリ | 含まれるパス |
|---|---|
| Webサイトファイル | /var/www(docroot、uploads、themes、plugins)および/rootと/homeディレクトリ |
| データベース | /var/lib/mysqlおよび/var/lib/postgresqlデータファイル |
| サーバー設定 | /etc、および/etc/letsencrypt証明書、/etc/ssh、/etc/ufwファイアウォールルール、/etc/fail2ban |
| Cronジョブとシステム状態 | /etc/cron.dおよび日次、時間単位、週単位のcronディレクトリ、/var/spool/cronユーザーcrontab、/etc/systemdユニット、およびcrontab、インストール済みパッケージ、有効なサービス、ファイアウォールステータスのキャプチャスナップショット |
| メール | メールがサーバーで設定されている場合のメールデータ |
揮発性で再構築可能なパスは意図的に除外されています: /proc、/sys、/dev、/run、/tmp、/var/tmp、/var/cache、/var/lib/docker/overlay2下のコンテナオーバーレイストレージ、およびスワップファイル。これらを除外することで、バックアップを小さく、高速に保ちながら、再生成できないものを失わないようにします。
バックアップはサーバーに固有のキーで暗号化され、オフサイトオブジェクトストレージに書き込まれます。パネルのみが復号化と復元を実行できます。
クラウドサーバーバックアップはサーバーをキャプチャします。それの外にあるものはキャプチャされません。別のホスト上の管理されたデータベース、外部支払いゲートウェイ、またはアプリケーションが通信する第三者サービスは、独自のデータを保持し、別々にエクスポートする必要があります。
バックアップリストの読み方
リストの各行には、バックアップが開始された時刻、完了後のサイズ、およびステータスピルが表示されます。
| ステータス | 意味 |
|---|---|
| Backed up | バックアップが完了し、復元可能なポイントです |
| Running | バックアップが進行中です |
| Failed | バックアップが完了しませんでした |
手動バックアップは日付の横にmanualタグが付きるため、日次実行と区別できます。完了したバックアップには、スナップショットリファレンス(サポートが特定の復元について支援が必要な場合に要求する識別子)も表示されます。
最新のバックアップが失敗した場合、カードにバナーが表示されます: 「最新のバックアップが失敗しました。日次スケジュールで再試行を続けます。ディスク容量を確認するか、これが継続する場合はサポートにお問い合わせください。」単一の失敗は通常ディスクの満杯が原因です。容量を解放すると、次のスケジュール実行は成功します。
オンデマンドでバックアップを取得する
危険なことをする直前に手動バックアップを取得します: 主要なパッケージアップグレード、データベース移行、依存するサービスへの設定変更、または何か不慣れなことを初めて試みる場合。
- サーバーのページを開き、Backupsカードを見つけます。
- カードヘッダーのBack up nowをクリックします。
- 確認メッセージ「バックアップが開始されました。しばらくするとリストに表示されます。」が表示されます。
- 実行はサーバーでバックグラウンドで行われます。数秒後にカードを更新して、Runningとして表示されるのを見て、その後Backed upに変わるのを見てください。
大きいサーバーは時間がかかります。完成した行のサイズ列には、キャプチャされたサイズが表示されます。
手動バックアップは選択した名前ではなく、タイムスタンプで識別されます。変更を加える直前にバックアップを取得するため、時刻が一致し、一目で「変更前」の復元ポイントがどれであるかを判断できます。
バックアップから復元する
- Backupsカード内で復元したい完了したバックアップを見つけます。
- その行のRestoreをクリックします。
- 確認メッセージを読みます: 「これはサーバーの現在のファイルを選択されたスナップショットの内容で上書きします。スナップショット以降に行われた変更はすべて失われます。サーバーは復元中もオンラインのままです。」
- Restoreをクリックして進めます。
復元は取り消せません。そのバックアップが取得されて以来書き込まれたすべてのデータは、バックアップの内容に置き換わります。現在の状態を取り戻したい可能性がある場合は、スナップショットを取得してから復元してください。
サーバーは復元の実行中もオンラインのままです。これにより、完全なダウンタイムなしで破損したアプリケーションを復元できます。大規模なファイルシステムは時間がかかります。5分後も復元が進行中の場合、KPanelは「予想より時間がかかり、サーバーで実行中です」と表示し、復元はバックグラウンドで続行されます。
バックアップとスナップショットの比較
サーバーには2つの独立した安全ネットがあり、どちらもさまざまな状況に適しています。
| バックアップ | スナップショット | |
|---|---|---|
| 保存場所 | 暗号化されたオフサイトストレージ | サーバーが実行されているプラットフォームの隣 |
| スケジュール | 日次、自動 | オンデマンド、およびすべてのパッチ実行の前に自動 |
| 保持期間 | 30日 | 不要になるまで保持 |
| 復元内容 | ファイル、データベース、設定(その場で) | ディスク全体、まさにその通り |
| 復元中のサーバー | オンラインのままです | 再起動します |
| 最適な用途 | データ保護と災害復旧 | 危険な変更の直前の安全ネット |
両方を使用してください。変更前のスナップショットは、変更がうまくいかない場合に最速で戻る方法です。バックアップは、数日後まで気付かない問題から保護します。クラウドサーバースナップショットはスナップショット側を完全にカバーしています。
バックアップと再構築
サーバーのオペレーティングシステムを再構築すると、ディスク全体が削除されます。これには、復元ツールが含まれています。バックアップデータはオフサイトストレージで安全ですが、パネルのRestoreボタンは再構築されたサーバーでそれを使用できません。クラウドサーバーの再構築を完全に読み、再構築する前に必要なものをダウンロードしてください。
トラブルシューティング
「バックアップはまだこのサーバーに対して設定されていません。」これらはプロビジョニング時に自動的に有効になります。新しいサーバーにこれが表示されている場合は、数分待ってください。継続する場合はお問い合わせください。
「バックアップがまだありません。」最初のバックアップはプロビジョニング直後に自動的に実行されます。待つ代わりにBack up nowをクリックすることもできます。
「手動バックアップは一時的に利用できません。」パネルが実行を開始するためにサーバーに到達できませんでした。サーバーが実行中で到達可能であることを確認してから、もう一度お試しください。
完了したバックアップに復元ボタンがありません。復元には、バックアップツールが存在する到達可能でプロビジョニングされたサーバーが必要です。再構築されたサーバー、または電源が切られたサーバーは、それを提供しません。
バックアップが繰り返し失敗し、ディスク容量が原因でない場合は、support@kapsulehost.comにサーバー名と失敗した実行のタイムスタンプを記載したメールを送信してください。