クラウドサーバーのリサイズは、プロセッサーファミリー内でサーバーを上下のティアに移動させ、CPU、メモリ、ディスクを変更しますが、データの移動やIPアドレスの変更は行いません。
注文時に容量を推測する必要はありません。今日のワークロードに合わせて開始し、数字が示すときに移動してください。このガイドでは、リサイズ画面、アップグレードとダウングレードが請求に与える影響、元に戻せない1つのこと、および必要なティアの在庫がない場合の対処方法について説明します。
リサイズで変更できることと変更できないこと
| 変更される | 変わらない |
|---|---|
| vCPU数 | IPv4およびIPv6アドレス |
| メモリ | リージョン |
| ディスク(アップグレード時) | オペレーティングシステムとインストール済みのすべて |
| 月額料金 | データ |
リサイズにより、同じプロセッサーファミリーと同じ管理モード内に留まります。CometからAtlasへ、またはQuasarからOrionへ移動できますが、ARMティアからStandard x86ティアにリサイズすることはできません。また、アンマネージドCloud VPSをManaged Cloud Serverにリサイズすることもできません。これらは異なるハードウェアを備えた異なる製品です。ファミリーを変更するには、新しいサーバーを注文して移行します。ARM、Standard、Dedicated vCPUサーバーの選択を参照してください。マネージドとアンマネージド間で移動するには、チームにお問い合わせください。
ベアメタルサーバー、ストレージサーバー、GPUサーバーはその場でリサイズできません。リサイズ画面に直接表示されます。「ライブリサイズはクラウドティア(ARM、x86、dedicated-vCPU)で利用可能です。ベアメタル、ストレージ、GPUサーバーは新しいサーバーを注文することで変更されます。」
リサイズ画面を開く
- KPanelにサインインします。
- 左側のサイドバーでCloud Serversをクリックし、サーバーをクリックします。
- Resize Serverカードを見つけてRegion-aware resizeをクリックします。
直接アドレスは/cloud-servers/<server-id>/resizeです。

画面には3つの部分があります。
- 現在のティア - 既存ティア、その仕様、月額料金、リージョンを表示します。
- 新しいティアを選択 - ファミリー内のすべての他のティアを上下矢印付きで列挙し、その仕様、価格、ライブ在庫バッジを表示します。
- サマリー - 右側にあり、対象を選択するとフィルされます。
在庫バッジはページを開いた時点でライブで読み込まれます:In stock、Reserve、Limited stock、またはUnavailable here。
ターゲットティアの選択
リストのティアをクリックします。サマリーパネルには以下が表示されます。
| 行 | 説明 |
|---|---|
| 新しいティア | 選択したティア |
| 方向 | アップグレードまたはダウングレード |
| リージョン | サーバーのリージョン(変更なし) |
| 新しい月額 | 請求通貨での新しい月額料金 |
価格の下には、プレーンテキストで「月額{金額}増」または「月額{金額}減」の差額が表示され、キャプションでGSTを除いた価格であることを確認します。アカウント通貨がNZDの場合、チェックアウト時にGSTが追加されます。クラウドサーバーの料金とGSTを参照してください。
下のRegional availabilityパネルは、選択したティアが現在容量を持つ場所を表示します。これは情報提供のみです。サーバーはいずれの方法でも現在のリージョンに留まります。リサイズはデータをリージョン間で移動することはありません。
アップグレード
Resize toの後にティア名をクリックします。
アップグレードはすぐに適用されます。
- アップグレードについて即座に課金されます。請求期間の途中である場合、残りの期間に対して按分され、更新金額はその後新しいティアの価格に更新されます。
- 支払いが成功すると、サーバーは物理的にリサイズされます。
- リサイズ中にサーバーは短く再起動します。長い停止ではなく、短い中断を予想してください。
- 戻ると、新しいCPU、メモリ、ディスクはすぐに利用可能になります。
順序が重要です。課金が最初に行われるため、カードが拒否されるとサーバーに何もする前に失敗します。課金が失敗した場合、何も変更されず、支払い方法を修正して再度試行できます。支払い方法の更新を参照してください。
リサイズは課金対象を変更するため、アカウントが以前見たことのないデバイスからサインインしている場合、KPanelは最初に再認証を求める可能性があります。これは計画変更を保護するのと同じステップアップチェックです。
ダウングレード
ダウングレードはその場で適用されるのではなく、スケジュール設定されます。
- 現在は課金されません。
- より大きいサーバーは、既に支払った価格で、支払った請求期間の終了まで保持されます。
- 更新時に、プランは小さいティアに切り替わり、更新価格は新しいティアの価格に低下し、サーバーは同時に物理的にリサイズされます。
これは意図的です。より大きいサイズで期間の料金を支払ったため、その期間全体をより大きいサイズで取得します。
ディスクは拡大できますが、縮小することはできません。ダウングレード時、現在のディスクサイズは保持され、CPU和メモリのみが削減されます。これはデータにとって良いことですが、ダウングレード時に使用中のディスクを削減できず、後のアップグレードは既に持っているディスクから開始されることを意味します。
ダウングレードが有効になる前に、小さいティアが実際にワークロードを処理できることを確認してください。サーバーページのLive metricsカードでCPUとメモリを過去24時間確認し、ピークを平均値ではなくターゲットティアと比較してください。
必要なティアの在庫がない場合
一部のティア(特にARM)は売り切れます。選択したティアにリージョン内の容量がない場合、サマリーパネルはリサイズボタンから予約ボタンに切り替わり、理由を説明します。「このティアは現在在庫がありません。予約してください。在庫が戻ると自動的にプロビジョニングします。プロビジョニングされるまで課金されません。」
Reserveの後にティア名をクリックすると、予約参照番号が表示されます。予約は無料で、待機中は課金されず、いつでもキャンセルできます。リージョン、可用性、予約キューは完全なキューについて説明します。
ページを読み込んだときのティアが在庫にあり、確認までになくなることもあります。KPanelはそれを処理し、失敗しません。ティアが在庫がないことを通知し、代わりに予約パスを提供します。
リサイズ前に
最初にスナップショットを取得してください。リサイズは実績のある操作で、滅多に失敗しませんが、スナップショットは2分かかり、再起動後にアプリケーションが正常に戻らないケースをカバーしています。
また、実施する価値のあることは以下の通りです。
- 静かなウィンドウを選択してください。再起動は短いですが、実際のダウンタイムです。
- アプリケーションが起動時にCPU数またはメモリサイズ自体に固定されているかどうかを確認してください。一部のランタイムとデータベースはリソース変更後に設定調整が必要です。
- 現在のティア名をメモしておき、戻す方法がわかるようにしておいてください。
トラブルシューティング
「このファミリーに移動できる他のティアがありません。」 このファミリーの唯一のティアの上にいるか、他のティアは現在販売不可です。異なるファミリーで新しいサーバーを注文することが前進する方法です。
「このサーバーはその場でリサイズできません。」 サーバーはベアメタル、ストレージ、GPUであるか、現在のラダーに属していないレガシープランにあります。お問い合わせください。オプションについて説明いたします。
「このサーバーはまだ請求サブスクリプションにリンクされていません。」 パネルはマシンを変更しながら請求も変更しません。サポートにお問い合わせください。リンクいたします。
リサイズが支払いのため拒否されました。 課金はサーバーに触れる前に行われるため、拒否されたカードは操作全体を安全に停止します。支払い方法を更新して再度試行してください。
「マネージドアカウントはホスティングプロバイダー経由でプランを変更します。」 アカウントはリセラーによって管理されています。彼らはあなたのための計画変更を制御しています。
サーバーが再起動後に戻りませんでした。 数分待ってリロードしてください。まだダウンしている場合は、SSH でクラウドサーバーに接続するで説明されているブラウザコンソールを使用するか、事前に取得したスナップショットにロールバックしてください。
リサイズが予期しない状態でサーバーを残した場合は、サーバー名、移動元ティア、移動先ティアを記載してsupport@kapsulehost.comにメールしてください。