调整服务器大小会在同一处理器系列内将您的服务器上下移动各级别,改变 CPU、内存和磁盘,而无需移动您的数据或更改您的 IP 地址。
订购时您无需猜测容量。从您当前的工作负载开量开始,根据数字变化进行调整。本指南涵盖调整大小屏幕、升级和降级分别如何影响您的账单、无法反转的一项内容,以及当您所需的级别缺货时该怎么办。
调整大小可以和不可以更改的内容
| 可以更改 | 保持不变 |
|---|---|
| vCPU 数量 | 您的 IPv4 和 IPv6 地址 |
| 内存 | 您的区域 |
| 磁盘(升级时) | 您的操作系统和已安装的所有内容 |
| 您的月价格 | 您的数据 |
调整大小会让您保持在同一处理器系列和同一管理模式内。您可以从 Comet 移至 Atlas,或从 Quasar 移至 Orion,但您不能从 ARM 级别调整大小到标准 x86 级别,也不能将非托管 Cloud VPS 调整为托管云服务器。这些是具有不同底层硬件的不同产品。要更改系列,请订购新服务器并迁移;请参阅 ARM、标准和专用 vCPU 服务器之间的选择。要在非托管和托管之间移动,请联系我们的团队。
裸机服务器、存储服务器和 GPU 服务器无法就地调整大小。调整大小屏幕会直接说明:"实时调整大小适用于云层级(ARM、x86 和专用 vCPU)。裸机、存储和 GPU 服务器通过订购新服务器来更改。"
打开调整大小屏幕
- 登录 KPanel。
- 点击左侧边栏中的云服务器,然后点击您的服务器。
- 找到调整服务器大小卡片,并点击区域感知调整大小。
直接地址是 /cloud-servers/<server-id>/resize。

该屏幕有三个部分:
- 当前级别,显示您现有的级别、其规格、其月价格和其区域。
- 选择新级别,列出您的系列中的所有其他级别,带有向上或向下箭头、其规格、其价格和实时库存徽章。
- 摘要,在右侧,一旦您选择目标就会填充。
库存徽章在您打开页面时实时读取:有库存、预留、库存有限或此处无库存。
选择目标级别
点击列表中的一个级别。摘要面板随后显示:
| 行 | 它告诉您什么 |
|---|---|
| 新级别 | 您选择的级别 |
| 方向 | 升级或降级 |
| 区域 | 您服务器的区域,不会更改 |
| 新月价 | 您的账单货币中的新月价格 |
价格下方您会看到用简单语言表示的差异,要么是"US$9.00每月更多",要么是"US$9.00每月更少",以及一个标题确认价格显示不包括 GST,如果您的账户货币是 NZD,则在结账时添加 GST。请参阅 云服务器定价和 GST。
下方的区域可用性面板显示选定级别当前在何处有容量。这只是信息性的:无论哪种方式,您的服务器都保持在其当前区域。调整大小永远不会在区域之间移动您的数据。
升级
点击调整大小为,然后是级别名称。
升级立即应用:
- 升级费用立即向您收取。如果您处于计费周期的中途,费用按剩余时间按比例计算,您的续订金额从那时起更新为新级别的价格。
- 支付成功后,服务器会进行物理调整。
- 服务器在调整大小期间会短暂重启。预期短时间中断,而不是长时间停机。
- 恢复后,新的 CPU、内存和磁盘立即可用。
顺序很重要:费用首先发生,因此被拒卡会在对服务器进行任何操作之前失败。如果费用失败,什么都不会改变,您可以修复付款方式并重试。请参阅 更新您的付款方式。
调整大小会改变您的收费方式,因此如果您从该账户之前未看到的设备登录,KPanel 可能会要求您首先重新进行身份验证。这是保护任何计划更改的相同升级检查。
降级
降级是计划的,而不是立即应用。
- 您现在不收取任何费用。
- 您保留较大的服务器,按照您已经支付的价格,直到您已支付的计费周期结束。
- 在续订时,计划切换到较小的级别,续订价格下降到新级别的价格,服务器同时进行物理调整。
这是有意的:您为较大规模的一个周期付费,所以您获得整个周期的较大规模。
磁盘可以增长,但永远不能缩小。当您降级时,您当前的磁盘大小会被保留,只有 CPU 和内存被减少。这对您的数据有好处,但这意味着降级不会减少您正在使用的磁盘,后来的升级会从您已有的磁盘开始。
在降级生效之前,请确保较小的级别确实能够承载您的工作负载。检查服务器页面上的实时指标卡片,查看过去 24 小时的 CPU 和内存,并将峰值(而不是平均值)与目标级别进行比较。
当您所需的级别无库存时
一些级别,特别是 ARM,会售罄。如果您选择的级别在您的区域中没有容量,摘要面板会从调整大小按钮切换到预留按钮,并解释原因:"此级别现在缺货。预留它,我们会在库存返回时自动预配它。在预配之前,您无需支付费用。"
点击预留,然后是级别名称,您会获得一个预留参考。预留是免费的,您在等待时不会被计费,您可以随时取消。区域、可用性和预留队列详细解释了队列。
有时一个级别在页面加载时有库存,到您确认时已消失。KPanel 处理这种情况而不是失败:它告诉您该级别缺货并提供预留路径。
在您调整大小之前
首先拍摄快照。调整大小是一项经过考验的操作,很少出错,但快照花费您两分钟并涵盖您的应用在重启后没有干净返回的情况。
其他值得做的事情:
- 选择一个平静的时间窗口。重启很短,但这是真正的停机时间。
- 检查您的应用在启动时是否将自己固定到 CPU 计数或内存大小。某些运行时和数据库需要在资源更改后调整其配置。
- 记下您当前的级别名称,以便您知道可以返回到什么。
故障排除
"此系列中没有其他级别可以移动到。" 您处于该系列中的唯一级别,或其他级别当前无法销售。在不同系列中订购新服务器是前进的方式。
"此服务器无法就地调整大小。" 服务器是裸机、存储或 GPU,或它处于不是当前阶梯的一部分的遗留计划上。联系我们,我们会讨论选项。
"此服务器尚未链接到计费订阅。" 该面板不会在不同时更改账单的情况下更改计算机。联系支持,我们会链接它。
调整大小因付款被拒绝。 费用在触及服务器之前被取走,因此拒卡会安全地停止整个操作。更新您的付款方式并重试。
"托管账户通过其托管提供商更改计划。" 您的账户由转销商管理。他们为您控制计划更改。
服务器在重启后未返回。 等待几分钟并重新加载。如果它仍然关闭,请使用 使用 SSH 连接到您的云服务器中描述的浏览器控制台,或回滚到您预先拍摄的快照。
如果调整大小使您的服务器处于您未预期的状态,请向 support@kapsulehost.com 发送电子邮件,包含服务器名称、您从其移动的级别和您移动到的级别。